Supported versions


Data services

PDS supports the following data services and versions:

Data service

Version

Apache Cassandra

  • 4.0.6

  • 3.11.13

  • 3.0.27

Apache Kafka

  • 3.2.3

  • 3.1.1

  • 3.0.1

MySQL

  • 8.0.30

PostgreSQL

  • 14.5

  • 13.7

  • 12.11

  • 11.16

  • 10.21

RabbitMQ

  • 3.10.9

  • 3.9.22

Redis

  • 7.0.4

Apache ZooKeeper

  • 3.8.0

  • 3.7.1

  • 3.6.3

Platforms

PDS supports clusters on the following platforms:

Platform

Version

Vanilla Kubernetes on-premises

  • 1.21

  • 1.22

  • 1.23

  • 1.24

Amazon Elastic Kubernetes Service (EKS)

  • 1.21

  • 1.22

Microsoft Azure Kubernetes Service (AKS)

  • 1.21

  • 1.22

OpenShift Container Platform (OCP)

  • 4.8

  • 4.9

vSphere with Tanzu (TKGs)

1.22.9+vmware.1-tkg.1.cc71bc8

Rancher Kubernetes Engine (RKE1)

1.23.8

RKE2

1.24.4+rke2r1

Google Kubernetes Engine (GKE)

1.23.8-gke.1900

Anthos

1.21.13-gke.202

NOTE: From the PDS 110 release, you must install the PDS Helm chart version 1.9.0 or newer to ensure new PostgreSQL versions are compatible with older chart versions (until 1.8.1).

Portworx Enterprise compatibility

PDS is compatible with the following Portworx enterprise versions:

  • 2.12.x

  • 2.11.x

  • 2.10.x

Backup Targets

PDS supports backup targets on the following storage providers:



Last edited: Thursday, Dec 1, 2022